use strict;
my $str = '123 Main St, Los Angeles, CA, 90210
123 Main St, North Las Vegas NV, 90210
123 Main St, Winston–Salem NC, 90210
123 Main St, St. Petersburg PA 90210-1111
123 Main St, Port St. Lucie PA 90210-1111';
my $regex = qr/(?<=,\s)([A-Z].*?)(?=[,\s]*[A-Z]{2}[,\s]*\d{5}(?:-\d{4})?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}