using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,\s)([A-Z].*?)(?=[,\s]*[A-Z]{2}[,\s]*\d{5}(?:-\d{4})?)";
string input = @"123 Main St, Los Angeles, CA, 90210
123 Main St, North Las Vegas NV, 90210
123 Main St, Winston–Salem NC, 90210
123 Main St, St. Petersburg PA 90210-1111
123 Main St, Port St. Lucie PA 90210-1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}