#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^$|^(?!00:00)(([01][0-9])|(2[0-3])):[0-5][0-9]$"
Local $sString = "00:01" & @CRLF & _
"00:10" & @CRLF & _
"01:00" & @CRLF & _
"12:01" & @CRLF & _
"13:01" & @CRLF & _
"23:59" & @CRLF & _
"00:00" & @CRLF & _
"23:60" & @CRLF & _
"24:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")