using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$|^(?!00:00)(([01][0-9])|(2[0-3])):[0-5][0-9]$";
string input = @"00:01
00:10
01:00
12:01
13:01
23:59
00:00
23:60
24:00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}