re = /^$|^(?!00:00)(([01][0-9])|(2[0-3])):[0-5][0-9]$/m
str = '00:01
00:10
01:00
12:01
13:01
23:59
00:00
23:60
24:00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end