const regex = /^$|^(?!00:00)(([01][0-9])|(2[0-3])):[0-5][0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^$|^(?!00:00)(([01][0-9])|(2[0-3])):[0-5][0-9]$', 'gm')
const str = `00:01
00:10
01:00
12:01
13:01
23:59
00:00
23:60
24:00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}