package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[\^\d+)\) `)
var str = `[^19) Jones, Owen.`
var substitution = "\1] "
fmt.Println(re.ReplaceAllString(str, substitution))
}