import re
regex = re.compile(r"(\[\^\d+)\) ", flags=re.MULTILINE)
test_str = "[^19) Jones, Owen."
subst = "\\1] "
result = regex.sub(subst, test_str)
if result:
print(result)