const regex = new RegExp('(\\[\\^\\d+)\\) ', 'gm')
const str = `[^19) Jones, Owen.`;
const subst = `\1] `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);