using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\(\[`])big(?!.*[\)\]`])";
string input = @"Should Match:
I like `xx` big `xx` cakes
I like big cakes
I like `big cakes
I like big` cakes
I like xx big xx cakes
I like ` xx big xx cakes
I like xx big xx` cakes
I like `xx` big `xx` cakes
I like big cakes
I like [big cakes
I like big] cakes
I like xx big xx cakes
I like [ xx big xx cakes
I like xx big xx] cakes
I like [xx] big [xx] cakes
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
I like (xx) big (xx) cakes
I like (xx(test(big test big ( big ))) big xx) big (xx(test(big test big ( big ))) big xx) cakes
^^^
Should not Match:
I like (big) cakes
I like (xx big xx) cakes
I like [big] cakes
I like [xx big xx] cakes
I like `big` cakes
I like `xx big xx` cakes
I like (xx(test(big test big ( big ))) big xx) cakes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}