const regex = new RegExp('(?<![\\(\\[`])big(?!.*[\\)\\]`])', 'gm')
const str = `Should Match:
I like \`xx\` big \`xx\` cakes
I like big cakes
I like \`big cakes
I like big\` cakes
I like xx big xx cakes
I like \` xx big xx cakes
I like xx big xx\` cakes
I like \`xx\` big \`xx\` cakes
I like big cakes
I like [big cakes
I like big] cakes
I like xx big xx cakes
I like [ xx big xx cakes
I like xx big xx] cakes
I like [xx] big [xx] cakes
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
I like (xx) big (xx) cakes
I like (xx(test(big test big ( big ))) big xx) big (xx(test(big test big ( big ))) big xx) cakes
^^^
Should not Match:
I like (big) cakes
I like (xx big xx) cakes
I like [big] cakes
I like [xx big xx] cakes
I like \`big\` cakes
I like \`xx big xx\` cakes
I like (xx(test(big test big ( big ))) big xx) cakes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}