$re = '/(?<![\(\[`])big(?!.*[\)\]`])/m';
$str = 'Should Match:
I like `xx` big `xx` cakes
I like big cakes
I like `big cakes
I like big` cakes
I like xx big xx cakes
I like ` xx big xx cakes
I like xx big xx` cakes
I like `xx` big `xx` cakes
I like big cakes
I like [big cakes
I like big] cakes
I like xx big xx cakes
I like [ xx big xx cakes
I like xx big xx] cakes
I like [xx] big [xx] cakes
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
I like (xx) big (xx) cakes
I like (xx(test(big test big ( big ))) big xx) big (xx(test(big test big ( big ))) big xx) cakes
^^^
Should not Match:
I like (big) cakes
I like (xx big xx) cakes
I like [big] cakes
I like [xx big xx] cakes
I like `big` cakes
I like `xx big xx` cakes
I like (xx(test(big test big ( big ))) big xx) cakes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);