using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!\.)(?:(?:9[5-9]|10[0-5])(?:\.\d)?|106(\.0)?)(?!\.)\b";
string input = @"94.9 95 95.1 95.11 100 100.0 100x 1.100.1 y101 +104.2 103.2 105.99 106 106.0 106.1 107";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}