const regex = /\b(?<!\.)(?:(?:9[5-9]|10[0-5])(?:\.\d)?|106(\.0)?)(?!\.)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\\.)(?:(?:9[5-9]|10[0-5])(?:\\.\\d)?|106(\\.0)?)(?!\\.)\\b', 'gm')
const str = `94.9 95 95.1 95.11 100 100.0 100x 1.100.1 y101 +104.2 103.2 105.99 106 106.0 106.1 107`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}