#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<data name="([^"]*)">(?:(?!data).)*DoNotUse"
Local $sString = "<data name="A">" & @CRLF & _
" <value>A</value>" & @CRLF & _
"<comment>Bla Bla</comment>" & @CRLF & _
"</data>" & @CRLF & _
"<data name="B">" & @CRLF & _
" <value>B</value>" & @CRLF & _
"</data>" & @CRLF & _
"<data name="C">" & @CRLF & _
" <value>###DoNotUse###</value>" & @CRLF & _
" <comment>Bla Bla</comment>" & @CRLF & _
"</data>" & @CRLF & _
"<data name="D">" & @CRLF & _
" <value>D</value>" & @CRLF & _
" <comment>Bla Bla</comment>" & @CRLF & _
"</data>" & @CRLF & _
"<data name="E">" & @CRLF & _
" <value>###DoNotUse###</value>" & @CRLF & _
"</data>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")