import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<data name=\"([^\"]*)\">(?:(?!data).)*DoNotUse";
final String string = "<data name=\"A\">\n"
+ " <value>A</value>\n"
+ "<comment>Bla Bla</comment>\n"
+ "</data>\n"
+ "<data name=\"B\">\n"
+ " <value>B</value>\n"
+ "</data>\n"
+ "<data name=\"C\">\n"
+ " <value>###DoNotUse###</value>\n"
+ " <comment>Bla Bla</comment>\n"
+ "</data>\n"
+ "<data name=\"D\">\n"
+ " <value>D</value>\n"
+ " <comment>Bla Bla</comment>\n"
+ "</data>\n"
+ "<data name=\"E\">\n"
+ " <value>###DoNotUse###</value>\n"
+ "</data>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}