re = /(?s)<data name="([^"]*)">(?:(?!data).)*DoNotUse/m
str = '<data name="A">
<value>A</value>
<comment>Bla Bla</comment>
</data>
<data name="B">
<value>B</value>
</data>
<data name="C">
<value>###DoNotUse###</value>
<comment>Bla Bla</comment>
</data>
<data name="D">
<value>D</value>
<comment>Bla Bla</comment>
</data>
<data name="E">
<value>###DoNotUse###</value>
</data>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end