using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<data name=""([^""]*)"">(?:(?!data).)*DoNotUse";
string input = @"<data name=""A"">
<value>A</value>
<comment>Bla Bla</comment>
</data>
<data name=""B"">
<value>B</value>
</data>
<data name=""C"">
<value>###DoNotUse###</value>
<comment>Bla Bla</comment>
</data>
<data name=""D"">
<value>D</value>
<comment>Bla Bla</comment>
</data>
<data name=""E"">
<value>###DoNotUse###</value>
</data>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}