const regex = /^.*?,"([^"]+)".*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?,"([^"]+)".*', 'gm')
const str = `1234567,"ИНФОРМ4132","АБВ","1232-1213123-123"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);