use strict;
my $str = '1234567,"ИНФОРМ4132","АБВ","1232-1213123-123"';
my $regex = qr/^.*?,"([^"]+)".*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";