$re = '/^.*?,"([^"]+)".*/m';
$str = '1234567,"ИНФОРМ4132","АБВ","1232-1213123-123"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;