re = /^.*?,"([^"]+)".*/m
str = '1234567,"ИНФОРМ4132","АБВ","1232-1213123-123"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result