import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\\b)\\w+\\b(?=\\W*\\w+\\b)";
final String string = "De la cruz\n"
+ "de la cruz jr\n"
+ "santiago\n"
+ "smith\n"
+ "smith johnson\n"
+ "smith johnson II\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}