re = /\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\b)\w+\b(?=\W*\w+\b)/mi
str = 'De la cruz
de la cruz jr
santiago
smith
smith johnson
smith johnson II
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end