import re
regex = re.compile(r"\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\b)\w+\b(?=\W*\w+\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("De la cruz\n"
"de la cruz jr\n"
"santiago\n"
"smith\n"
"smith johnson\n"
"smith johnson II\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")