$re = '/\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\b)\w+\b(?=\W*\w+\b)/mi';
$str = 'De la cruz
de la cruz jr
santiago
smith
smith johnson
smith johnson II
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);