#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^.+;){1}.+$"
Local $sString = "Test;Test" & @CRLF & _
"Test; Test" & @CRLF & _
"Test;" & @CRLF & _
"Test;"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)