import re
regex = re.compile(r"(^.+;){1}.+$", flags=re.MULTILINE)
test_str = ("Test;Test\n"
"Test; Test\n"
"Test;\n"
"Test;")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)