using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\]]+([^\]]+[\]]){5}[^\]]+$";
string input = @"""[ 357\"",\""-0.9\"",\""99\"",\""16 ] ] ] ] ""
""[ 357\"",\""-0.9\"",\""99\"",\""16 ] ] ] ] ] ""
""[ 357\"",\""-0.9\"",\""99\"",\""16 ] ] ] ] ] ]""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}