package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\]]+([^\]]+[\]]){5}[^\]]+$`)
var str = `"[ 357\",\"-0.9\",\"99\",\"16 ] ] ] ] "
"[ 357\",\"-0.9\",\"99\",\"16 ] ] ] ] ] "
"[ 357\",\"-0.9\",\"99\",\"16 ] ] ] ] ] ]"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}