re = /^[^\]]+([^\]]+[\]]){5}[^\]]+$/m
str = '"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] "
"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] ] "
"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] ] ]"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end