#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?<status>Turn Off|Turn On|Execute)"
Local $sString = "Recorded value for [Turn On Test 123]" & @CRLF & _
"" & @CRLF & _
"Recorded value for [Turn On Test 456]" & @CRLF & _
"" & @CRLF & _
"Execute all Appliances" & @CRLF & _
"" & @CRLF & _
"In process to Execute"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")