re = /\[(?<status>Turn Off|Turn On|Execute)/m
str = 'Recorded value for [Turn On Test 123]
Recorded value for [Turn On Test 456]
Execute all Appliances
In process to Execute'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end