using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?<status>Turn Off|Turn On|Execute)";
string input = @"Recorded value for [Turn On Test 123]
Recorded value for [Turn On Test 456]
Execute all Appliances
In process to Execute";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}