$re = '/\[(?<status>Turn Off|Turn On|Execute)/m';
$str = 'Recorded value for [Turn On Test 123]
Recorded value for [Turn On Test 456]
Execute all Appliances
In process to Execute';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);