import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(?:\\\\{2})*\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"(*SKIP)(*F)|\\h+";
final String string = "title:\"tab system\" color:=\"blue\" price:>10\n\n"
+ "tit\\\"le:\"tab system\" color:=\"blue\" price:>10\n\n"
+ "tit\\\\\\\"le:\"tab system\" color:=\"blue\" price:>10\n\n"
+ "title:\"tab system\" color:=\"blue\" price:>10\\\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}