re = /(?<!\\)(?:\\{2})*"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/m
str = 'title:"tab system" color:="blue" price:>10
tit\\"le:"tab system" color:="blue" price:>10
tit\\\\\\"le:"tab system" color:="blue" price:>10
title:"tab system" color:="blue" price:>10\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end