$re = '/(?<!\\\\)(?:\\\\{2})*"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"(*SKIP)(*F)|\h+/m';
$str = 'title:"tab system" color:="blue" price:>10
tit\\"le:"tab system" color:="blue" price:>10
tit\\\\\\"le:"tab system" color:="blue" price:>10
title:"tab system" color:="blue" price:>10\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);