# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(^|\h+)\d{4}-\d{4}(\h+|$)/ /gu;t' <<< "Dimension Graphic Design
John Monaco 2000-2002 Information
Florida
A REASON TO SMILE
Craig Smith 1995-2000 Information
Texas
MY TEST
2017-2018 some text at end
some text at start 2010-2011"