const regex = /(?m)(^|\h+)\d{4}-\d{4}(\h+|$)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(^|\\h+)\\d{4}-\\d{4}(\\h+|$)', 'gu')
const str = `Dimension Graphic Design
John Monaco 2000-2002 Information
Florida
A REASON TO SMILE
Craig Smith 1995-2000 Information
Texas
MY TEST
2017-2018 some text at end
some text at start 2010-2011`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);