#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(?m)(^|\h+)\d{4}-\d{4}(\h+|$)"
Local $sString = "Dimension Graphic Design" & @CRLF & _
"John Monaco 2000-2002 Information" & @CRLF & _
"Florida" & @CRLF & _
"" & @CRLF & _
"A REASON TO SMILE" & @CRLF & _
"Craig Smith 1995-2000 Information" & @CRLF & _
"Texas" & @CRLF & _
"" & @CRLF & _
"MY TEST" & @CRLF & _
"2017-2018 some text at end" & @CRLF & _
"some text at start 2010-2011"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)