package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\h+)\d{4}-\d{4}(\h+|$)`)
var str = `Dimension Graphic Design
John Monaco 2000-2002 Information
Florida
A REASON TO SMILE
Craig Smith 1995-2000 Information
Texas
MY TEST
2017-2018 some text at end
some text at start 2010-2011`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}