#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^_]*_|_\d+_\d+\.[^.]*$"
Local $sString = "Doc20191001119049_fotocontargasx_3962122_943000.jpg" & @CRLF & _
"Doc201810011052053_fotoAssicurazioneCartaceo_3962128_943000.jpg" & @CRLF & _
"Doc201910011214020_fotoesterna_ant_396024_947112.jpg" & @CRLF & _
"Doc201710071149010_foto_TargaMid_4007396_95010.jpg"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)