const regex = /^[^_]*_|_\d+_\d+\.[^.]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_]*_|_\\d+_\\d+\\.[^.]*$', 'gm')
const str = `Doc20191001119049_fotocontargasx_3962122_943000.jpg
Doc201810011052053_fotoAssicurazioneCartaceo_3962128_943000.jpg
Doc201910011214020_fotoesterna_ant_396024_947112.jpg
Doc201710071149010_foto_TargaMid_4007396_95010.jpg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);