package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:1?[0-9])\b`)
var str = `A 20 year old programmer
A 52 year old politician
A 12 year old practitioner
Many many more of these...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}