re = /\b(?:1?[0-9])\b/m
str = 'A 20 year old programmer
A 52 year old politician
A 12 year old practitioner
Many many more of these...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end