$re = '/\b(?:1?[0-9])\b/m';
$str = 'A 20 year old programmer
A 52 year old politician
A 12 year old practitioner
Many many more of these...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);