const regex = /\b(?:1?[0-9])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:1?[0-9])\\b', 'gm')
const str = `A 20 year old programmer
A 52 year old politician
A 12 year old practitioner
Many many more of these...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}