use strict;
my $str = '//초록색으로 표시되는 부분(A)에는 객체의 속성값, 키값, 인덱스값을 각각 표현할 단어를 지정합니다
//빨간색 부분(B)에는 바인딩 할 객체를 지정합니다. \'.\'을 통해 내부 객체에 접근할수도 있습니다.
//전체적으로 A in B의 형태를 띄게 됩니다.
val, key, index in sampleObj.inner
val, key in sampleObj.inner
val in sampleObj';
my $regex = qr/((?:[a-zA-Z][0-9a-zA-Z]*)(?:\,\s*[a-zA-Z][0-9a-zA-Z]*){0,2})\s+in\s+([a-zA-Z][0-9a-zA-Z\.]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}