# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[a-zA-Z][0-9a-zA-Z]*)(?:\,\s*[a-zA-Z][0-9a-zA-Z]*){0,2})\s+in\s+([a-zA-Z][0-9a-zA-Z\.]*)"
test_str = ("//초록색으로 표시되는 부분(A)에는 객체의 속성값, 키값, 인덱스값을 각각 표현할 단어를 지정합니다\n"
"//빨간색 부분(B)에는 바인딩 할 객체를 지정합니다. '.'을 통해 내부 객체에 접근할수도 있습니다.\n"
"//전체적으로 A in B의 형태를 띄게 됩니다.\n\n"
"val, key, index in sampleObj.inner\n"
"val, key in sampleObj.inner\n"
"val in sampleObj")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.